To Evolve Customers with the Monet Software solution for Workforce Management:

Verint Monet Software Recently announced the deprecation for support using the security protocols TLS 1.0 and 1.1.  You may have received this communication directly from Verint Monet already.  This comes as no surprise to Evolve IP as many software companies are adapting to the latest security protocols of either TLS 1.2 or 1.3.  In this case, Monet Verint is utilizing TLS 1.2

What Actions Need to Be Taken to Remain Compliant?

  • Evolve IP does not need to update any services.  Our platforms that integrate with Monet Software are compliant with the TLS 1.2 protocol.
  • Your business needs to verify compatibility with browsers that support TLS 1.2.  Here are the most widely spread browsers and their versions that support v1.2 for you to check compatibility:
    • Google Chrome v30 and above
    • Mozilla Firefox v27 and above
    • MS Internet Explorer v11 and above (If using IE 10, make sure TLS 1.2 is enabled)
    • MS Edge

Workforce Management (WFM) software targets contact centers with 50 agents or more for productivity improvements.  WFM provides real-time and historical metrics to be used for scheduling, adherence, forecasting, staffing, reports and more.  To learn how other Evolve IP clients are taking advantage of WFM solutions with out platform, please contact your account manager for more details, qualifications and a demo.

If you have any questions about the TLS security update, please open a Priority 4 ticket with support@evolveip.net.